IMG 1 of 4
Our Price:
$56.99
RRP:
$63.25
You Save:
$6.26
or quickly purchase this product
In stock for shippingShips from our warehouse in 1-3 business days

Part Number:
442274
(?) Brand:
Manuf No:
USBWIN688U3
Shipping Weight:
0.1 KG (Includes product packaging)
Estimate Shipping
All stock codes associated to this product
NETWIN688U3, USBWIN688U3

Features

  • 1300 (867+400)Mbps wireless speed
  • Support 2.4GHz & 5GHz WLAN networks
  • Dual Band connections for lag-free HD video streaming and gaming
  • SuperSpeed USB 3.0 port, backward compatible to USB 2.0
  • Complies with IEEE 802.11ac, IEEE 802.11n, IEEE 802.11g, IEEE 802.11b standards
  • 20MHz & 40MHz & 80MHz bandwidth transmission
  • OFDM with BPSK, QPSK, 16QAM, 64QAM, 256QAMmodulation
  • Supports Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Specification

  • Hardware 
    • Ports: USB 3.0
    • Button: WPS 
    • LED: 1 X Link/ Active
    • Chipset:RTL8812AU 
    • Flash: N/A 
    • SDRAM: N/A 
    • Power Supply: USB 5V 
    • Power Plug: N/A 
    • Power Consumption:/ 
    • Rated Voltage/ requency /current:DC 5V about 500mA
  • Wireless 
    • Standard:IEEE802.11ac,IEEE 802.11a, IEEE 802.11b,IEEE 802.11g,IEEE 802.11n
    • Modulation:
      • 11ac\n: 16QAM, 64QAM 128QAM 256QAM with OFDM
      • 11g: BPSK, QPSK, 16QAM, 64QAM, OFDM
      • 11b: DQPSK, DBPSK, DSSS, CCK 
    • Speed:
      • 802.11ac: up to 867Mbps 
      • 802.11n: up to 400Mbps 
      • 802.11a: up to 54Mbps 
      • 802.11g: 54 M 
      • 802.11b: 11 M 
    • Frequency band:5GHz and 2.4GHz 
    • Power: 
      • 802.11b: 22dBm ± 2 dBm 802.11g: 16dBm ± 2 dBm 
      • 802.11n: 15dBm ± 2 dBm 802.11ac: 14dBm ± 2 dBm 
    • Distance:Outdoors 300m, Indoor 100m(According to the actual environment change)
    • Safely 64/128-bit WEP, AES,TKIP,WPA,WPA2,802.1x,WPA-PSK,WPA2-PSK,MAC, WDS
  • Environmental 
    • Operating Temperature:0ºC~40ºC 
    • Storage Temperature:-10~70 
    • Relative Humidity(Operational): 10%~90%,noncondensing 
    • Relative Humidity(Storage):10%~90%,noncondensing
  • Software
    • Standard Version 
      • RFC768 User Datagram Protocol(UDP)
      • RFC791 Internet Protocol(IP) 
      • RFC792 Internet Control Message Protocol
      • RFC793 Transmission Control Protocol(TCP)
      • bandwidth20MHz40MHz80MHz
      • Wireless Mode11ac only, 11n only, 11g only11b only(option)
    • System Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Product weight and dimensions

Item Weight: 0.25 KG
Product Dimensions: 98mm L x 28mm W x 10mm (L x W x H)

Package content

  • 1 x Wireless-AC USB3.0 Aapter
  • 1 x Quick Installation
  • 1 x CD driver

 

No additional files, specification sheets, guides or documentation found for product.

Warranty: 12 Month Return To Base

Full manufacturers warranty details are available at the manufacturers web site.

Unless otherwise specified Techbuy is normally your first point of contact for warranty related returns, further information regarding our warranty policies and consumer guarantees is available on our policies and service & support pages.

To apply for return of a product just go to our returns page.

These terms are in addition to and do not affect any terms, conditions, guarantees and warranties implied by law.

Visitor Reviews

[ There are no visitor reviews for this product yet]

Review Product
Click on a thumbnail to view it below

No related products found.

 
L7: 27 | TM: 9 | LM: 64 | TY: 405 | T: 2275
We accept the following with No surcharge on VISA, Mastercard and Paypal!
� Techbuy Pty Ltd 2000 - 2026 All rights reserved.
All prices shown on techbuy.com.au are in $AUD and inclusive of GST. Prices and availability are subject to change without prior notice. Images displayed are accurate to the best of our knowledge and we will not be held responsible for purchases based soley on these images. All brands and names are trademarks of their respective companies. Shipping Australia wide to all metro and regional areas (Sydney, Melbourne, Brisbane, Adelaide, Perth) and Internationally. For more information, please see our usage policies.